Page 1 of 1

Texture Issue I think?

PostPosted: Sun Aug 03, 2014 2:57 pm
by Lokichan
Hey, I have been trying to fix some of Kalian's Nameless hairs for use in my DRUMM mod.
When I say *fix* I mostly mean slightly adjusting meshes, adding ears, and replacing wonky textures.
I think I had a breakthrough last night because this side pony tail model I been working on looks quite beautiful in game.
The textures are high rez (not mine) and other than a few more tweaks to the mesh I think it will be ready to use!

BUT then I stepped inside, and out of natural light.
For the record I was testing this on my husbands comp which has MGSO set up with dynamic lighting, but the not so dark lighting version, and MGE but not MGE XE...not powerful enough XD

So anyways I notice almost immediately the lighting affects the color to extremes. My silver hair starts turning brownish, purplish, even pinkish in some lights. Candle and firelight. It keeps its natural color in just the right angle but as I walk through buildings it looks like the shade variance of an emo bag of skittles.

My question is this? Is there some setting I can adjust with the textures that might help with this issue? Or is there some crazy thing up with the mesh possibly? Any ideas or advice is appreciated, I would really love these to work but I don't want to put them in the mod if they cant stay one shade. If it helps at all these textures were brought over from an OB mod, (not the ones with n in that name.)

Thank you for any help you have to throw at me, and thank you for putting up with my questions :)

Re: Texture Issue I think?

PostPosted: Sun Aug 03, 2014 3:10 pm
by Drakkmore
Lokican it sounds like maybe it might be an issue with the specularity setting on the mesh. YOu might try adjusting it to be a little darker in Nifskope, btu I fear with Morrowind's engine there may not be much that can be done with that. Also try setting the emisive setting in Nifskope to darker too also.

Re: Texture Issue I think?

PostPosted: Sun Aug 03, 2014 5:39 pm
by Lokichan
Thank you! I will look up how to do that, and try that later tonight.
I'll report back to see how it does, thank you for the suggestion Drakkmore :D

Re: Texture Issue I think?

PostPosted: Sun Aug 03, 2014 5:55 pm
by Lokichan
Ok I found out Morrowind default is set to black on emisive and specularity, and I also found out how to adjust it :D
So I will try that first and lighten it if need be, crossing my tail.
And I will load up Niffy when I get home :)

Re: Texture Issue I think?

PostPosted: Mon Aug 04, 2014 2:05 am
by Lokichan
Yeah :( It look like already have that setting...sniff sniff now I don't know what to do.
I'll keep reading forums and tech stuff, but I have yet to find anything duplicating my problem.
Thank you though for that suggestion, its very appreciated...I might just have to bit the bullet, copy the alpha from an earlier version of this hair and use some older textures that don't reflect light color so much. I took the whit hair earlier...and it was reflecting the sunset XD

Re: Texture Issue I think?

PostPosted: Mon Aug 04, 2014 1:57 pm
by Drakkmore
hmmm yeah it seems like that might be the only solution then.
I was certain it would have been linked to specularity, and emmissiveness. I guess some texture colors really are effected by the lighting.
especially with the MCP settings new.

Re: Texture Issue I think?

PostPosted: Tue Aug 05, 2014 10:48 am
by Lokichan
I'm going to try messing with mesh settings in blender too, (with specularity and emmissiveness) perhaps it will help :)

Re: Texture Issue I think?

PostPosted: Thu Aug 07, 2014 8:21 pm
by Lokichan
Another random question...does morrowind have the capability of using egm files? That would make converting hair so much nicer if we could get it to auto fit heads ;) I'm assuming it doesn't but I thought I would ask in case someone knew :)