Page 1 of 1

Niskope assigning .tga instead of .dds

PostPosted: Tue Jun 26, 2012 8:22 am
by Melchior Dahrk
This little thing has been undeniably one of my most frustrating issues recently with editing meshes. For whatever reason (this didn't used to occur) nifskope has gotten it in it's head that I want all the texture paths to have .tga appended instead of .dds or whatever the texture actually is!

Anyone else beaten this problem before or have any idea what I can do? I tried looking through all the settings in nifskope and didn't find anything.

Thanks guys,
Melchior

Re: Niskope assigning .tga instead of .dds

PostPosted: Tue Jun 26, 2012 10:18 am
by Kiteflyer61
What are you using to edit?

If you're using nifskope it should use whatever file type the nif calls for by default. I don't know of a way to make it automatically use the dds extension. :(

If you're using blender for editing, there is a setting to "force .dds" on the export script page. This is particularly useful if you're editing vanilla meshes as the usually have a .tga extension set even though the game translates it to a .dds and uses a .dds texture. :D

Hope that helps. :D




KF

Re: Niskope assigning .tga instead of .dds

PostPosted: Tue Jun 26, 2012 12:24 pm
by Melchior Dahrk
Basically the issue is that the .nif will list the path as textures/WAR/war_de_f_face.tga or whatever when in reality that texture does not exist in that file-type and so the model shows up as texture-less (white). If I change .tga to .dds then it displays correctly because a file with that extension does exist.

edit: This is in nifskope if that wasn't clear. Thanks KF.